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STYLES

Creating & Applying Paragraph Styles
InDesign lets you create styles for 
character formatting, paragraph 
formatting, object formatting, even 
table formatting. Styles are important, 
because they let you apply or change 
a specific formatting with a single click. 
To open the Paragraph Style go to 
Window>Styles>Paragraph Styles.

The first thing you should know is that 
you should avoid basic paragraph 
style as much as we can. The easiest 
way to make a new style is to create an 
example of your paragraph style you 
want to use.  If you have a paragraph 
already formatted with the right size, 
and font, and everything, just put your 
text cursor in it or select some of the 
text. Then, go to the paragraph styles 
panel menu, (the little menu in the 
upper-right corner), and choose new 
paragraph style. The important thing 
here is because the cursor was inside 
that paragraph, it grabbed all of the 

formatting and it dropped it in the new style. Now, all you need to do is give it a name. 

You could also create a new style by going through all the panes on the left and choose a font, size, scaling, and so 
on. Before I clicking OK, go back to the general panel and check two things: First, apply style to selection, and second 
make sure the add to CC library checkbox is turned off.
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 Using Character Styles
The big difference between defining 
a paragraph style and a character 
style, is that paragraph styles always 
define all the character and paragraph 
formatting, the font, the size, the indents, 
everything that describes a paragraph. 
But character styles are different. They 
can be set up to define just one attribute, 
like just the font, or just the size, or the 
size and the color but nothing else. 

To open the Character Styles panel, go 
to Window>Styles>Character Styles. To 
create a brand new style, apply the same 
concept of the paragraph styles: make 
character styles based on an example 
and while your text is still selected, go 
back to your Character Styles panel, 
and then in the panel menu, choose New 
Character Style. Now, all the formatting 
that you did, are sucked up into the 
dialog box, the font, the color, and so 
on. All you need to do is give it a name. 
Now, every time you want to use that 
same character style, just select some 
text, and click on the new style. 

Character styles should only be applied to one letter, or one word, or maybe a sentence or two, 
but never, never an entire paragraph. This is really important. Character styles are only for a piece 
of a paragraph. If you need to apply formatting to an entire paragraph, use a paragraph style. 

Also you need to be careful to never click on any character styles when no text is selected on 
the page, because if you do, whatever style you click on becomes the new default style for the 
whole document, and then you'll end up accidentally applying it every time you create a new text 
frame. It's incredibly annoying, so make sure that the Character Styles panel is set to None unless 
you're actually applying a style. 
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Style overrides are shown as a little plus 
symbol in the paragraph or character 
styles panel. It means that there is 
a change of formatting on top of the 
paragraph style, something different. 
This is called a local override, and in 
fact, if you hover your cursor over that 
style, you'll see a little tool tip that shows 
you the override (for example the size 
and letting has been changed) . 

You can make local formatting or local 
overrides more obvious by clicking a 
little plus sign button in the upper right 
corner of the paragraph styles panel. 
That turns on the local override alert, 
which is this bright blue highlighting, 
and that just lets you know that there 
is formatting on top of or different than 
the paragraph style. 

Now if you ever have a document 
where you see that plus sign or blue 
highlighting, you can do one of two 
things. You can redefine the style to 
match the new formatting, or you can 
get rid of it by clicking anywhere inside 
the paragraph and then clicking on the 
remove local overrides button down at 

the bottom of the paragraph styles panel. As soon as you click remove overrides, anything that was done to 
that paragraph on top of the paragraph style definition is removed, and the plus sign and the highlighting 
disappears. 

There are two ways to edit a style, either a paragraph style or a character style. The first way is to change it 
on the page, and go to the paragraph styles panel menu, and choose Redefine Style. This feature takes the 
formatting from wherever the cursor is selected, and redefines the style based on it. 

Another way of editing styles is in the dialogue box. You can edit styles inside the paragraph or character styles 
panel by right-clicking on the style  and choose edit. Make any change you want and click OK. One important 
thing is to know that you can double click a style inside the panel to edit it, but it is better not to, because it is 
too easy to accidentally apply it to some text or make your document default style.

STYLES
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You can define an object 
style which with a single click 
will apply all sorts of object 
formatting, such as fill, stroke, 
transparency effects, and 
more. 

First, apply some formatting 
to an object and once done 
open the object styles panel. 
If you don't see it in the dock, 
make sure you are in the 
advanced work space up in 
the application bar or simply 
go to Windows>Styles>Object 
Styles. Create a new object 
style by going to the panel 
menu and choosing new 
object style and you can even 
add some additional features 
in the dialog box. 

Next time you want to apply 

that object style, simply select a frame and then click on the object style. 

Now of course, just like paragraph and character styles, it's really easy to edit these styles. Just make 
some changes to the object itself and go to the object styles panel, open the menu, and choosing 
redefine style.  You can also make changes by right-clicking on the style  and choose edit.

STYLES
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Creating a Table
With inDesign, you can make tables 
to easily throw a bunch of info into the 
page making it readable. Tables, are 
always anchored inside of a text frame, 
sometimes in the middle of a story or 
sometimes as the only thing in the text 
frame. Place your text cursor in the 
text frame, then go to the Table>Insert 
Table. The insert table dialogue box lets 
you choose the number of rows and 
columns and also specifies header and 
footer rows. You can type some words 
and press the tab key to jump from 
one field to the next. You don't have to 
make a text frame first. You coud Insert 
a Table from the table menu and in that 
case, InDesign will make a text frame 
for you and then put the table into it. 

If the data you need to insert comes 
from Word or Excel or some database, 
go to the file menu and choose Place. 
Excel documents will be imported as 
tables already, but if you are importing 
a Word document, select all the content 
and go to Table>Convert Text to Table. 

InDesign is going to ask you what is in between each row and column and you can leave that to default settings 
and click okay. 

If there is more data than you can see in this table, you can make the text frame bigger or thread it to a new frame. 
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To adjust any rows or columns in your 
table, choose the selection tool, and drag 
over one of the column dividers. Tables 
are always inside text frames, so you 
have to use the type tool to do almost 
anything to a table. When your cursor is 
inside of a cell, you can drag the row and 
column lines and they all move together. 
If you want to move a column divider 
without moving the other dividers, hold 
down the shift key and drag. Notice that 
the shift key does something different if 
you use it on the outside edge.  You should 
explore how you can drag the rows and 
columns to get used to the idea.

If I wanted the columns to be all the same 
width, select at least one cell from each 
column dragging over them. Then go to 
Table>Distribute Columns Evenly. Notice 
that when you choose one or more cells, 

the control panel changes to give you a bunch of table formatting features. You can do text formatting 
inside these cells, adjust the number of rows and columns, add or remove rows. If you want to get 
access to some table features, open the table panel by going to the Window>Type and Tables>Table. 
These features lets you set the width of the columns or the height of the row, specify an exact height 
for that row, precisely set the width of one or more columns, change the number of rows and columns 
in your table and you could tell it if you want the row above or below the current row. .2

TABLES

To add or delete just place your cursor inside any row or column, then head up to the table menu and choose from the delete sub menu.
To merge the cells together go to Table>Merge Cells.  To split individual cells into two go to Table>Split Cell Horizontally.  To move a whole 
row to a different place in the table, select that row by moving the cursor over to the left of the rows, and then click when you see a thick 
black arrow. To select more arrows, drag from one row to the next one down. Once the rows are selected, you can move them by placing 
your cursor over any of the cells inside those rows. You'll see a big thick line indicating where these cells are going to be dropped.
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To make the table look 
better, go to Table>Table 
Options, and then choosing 
table setup. The table 
options dialogue box gives 
you a lot of control over your 
tables. You can modify the 
dimentions, border, spacing, 
colors, tint and much more. I 
invete you to look around and 
exoerience all the features 
given in this pannel.

 
To look at the table 
without the extras go to 
View>extras>Hide-Frame 
Edges. 

To convert rows to header go 
to Table>Convert Rows>To 
Header.

To convert rows to Footers go 
to Table>Convert Rows>To 
Footer.

.2
TABLES
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To formate the data inside the cells,  
you can use the top Control Panner 
changing the row color or font size, but 
also you can apply a Paragraph Style. 
To do that, open the Paragraph Styles 
panel and place your text cursor inside 
any paragraph to apply the desired 
style. 

To change the strokes the a look at the 
icon in the middle of the Control Panel. 
When it comes to Formatting Tables it's 
really important that you understand 
what this icon represents. Each of 
the blue lines represents the strokes 
inside the current selection of cells. The 
bottom line and the top line represent 
the bottom most and top most lines in 
the selection. Not the whole Table, just 
the selection. Same thing with the left 
and right. The left and right lines inside 
this icon represent the leftmost and the 
rightmost columns inside the selection. 
The lines in the middle represent the 

middle strokes. If you want to change the strokes of each of those columns you need to turn off all of 
the strokes on the outside and turn on the ones in the middle. You can turn on or off a stroke simply 
by clicking on it in the icon. 

Another way to modify the cells is to select all the cells you want to modify and go to Table>Cell Options. 
This Cell Options dialog box gives you all kinds of control over each cell that you've selected. For example, 
you could change how far the text is going to sit from the edge of the cell or more. Take a look and explore!.2

TABLES
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InDesign is a tool for laying out pages 
and those could be either print pages 
or interactive on-screen pages. The 
three main interactive formats that 
InDesign supports are PDF, EPUB and 
Publish Online. Each one of this support 
different types of interactivity. Like EPUB 
(electronic publication) and Publish 
Online, support animation, but not form 
fields and you can make a PDF with 
interactive form fields but it doesn't 
currently support animation. 

There's one thing that all these formats 
support very well and that's Hyperlinks. 
When you are making a hyperlink, you 
can either select text with a type tool 
or an object with a selection tool. Open 
the hyperlinks panel from the Window 
menu by choosing Interactive, or go 
to the application bar, and change 
the workspace from advanced to 
interactive for PDF workspace. This 
workspace gives me most of the tools 
you need to make interactive files. 

In the Hyperlink Panel you can add a 
hyperlink by typing a web address in 

the URL field, and also, you have all kinds of options like changing the URL, to a page specific page inside the document. 
To do that, yout select the word and in the Hyperlink panel clink on the page icon at the bottom right. You can also 
change the underline text by setting the style pop up menu from hyperlink to none. Every time you create a hyperlink 
an icon appears at right column of the panel, and this icon tells me that this is a page link and if I click on it, it'll actually 
take you to that page. .2

INTERACTIVE DOCUMENTS
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  Creating an Interactive PDFIf you create an interactive document 
designed to be viewed on screen, 
you can create buttons to add some 
interactivity. To make a go to next 
page button, open your Buttons and 
Forms Panel. You can turn any shape 
into a button by clicking on the little 
button at the bottom of the buttons 
and forms panel. As soon as you do 
that you'll see the dash line change 
around the shape and the panel 
springs to life. To start adding actions 
to this button. First, give it a name and 
change the event filed to go to next 
page. Now you are ready to set the 
button up so it does some action on 
a particular event, like on click, go to 
the next page. You can see a list of all 
the actions on the pop up menu (the 
one with a plus symbol). You can also 
add a rollover effect by clicking on 
the rollover state, down in the middle 
of the panel. At the beginning  both 
normal and rollover look exactly the 
same, so you need to change the 
rollover effect like the color or stroke. Once you are done, you can see your PDF in action by exporting it. Go to File>Export and in the format 

pop up menu, there are two options for making a PDF. Interactive or print and choose interactive. 
You will have a number of options like making sure the PDF fits the entire page in the window, or 
the resolution to 150 PPI. When you click export, InDesign will write this PDF to the disk, and then it'll 
automatically open it in acrobat. Note that you do have to have Flash Player installed on your system 
in order to play some kinds of interactive media, such as movie and audio files. And some interactive 
features, such as these buttons may not work on tablets and mobile devices, such as the iPad.
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Exporting to the Web with Publish Online
With Adobe's publish online 
technology you can export any 
InDesign file to publish online and it 
appears on the web, along with any 
interactivity you put in it, including 
hyperlinks, buttons, animations, 
videos, slideshows, even embedded 
HTML widgets like Google Maps, and 
more. 

To animate the images of a 
document, you need the animation 
panel, choosing one of the built 
in animations. You can't play the 
animation on your InDesign page, 
but InDesign has a feature that can 
show you what it'll look like when you 
export it Window>Interactive>SWF 
preview. When you open the panel, 
InDesign exports the current page 
to a local temporary HTML file, and 
then opens it in the panel. To add 
a video just import it like any other 
graphic. Select the frame, go to the 
file menu, and choose place. Import 
a file like .mp4 which is a movie 
format that InDesign can read. 

To export the document and see how it looks. Click the publish online button up in the application bar, or go to the 
file menu and choose publish online. 

There are a few things you need to know about publish online. First, this is an Adobe Creative Cloud service, and 
the files are hosted on Adobe servers. That means, you can't just export HTML and put it on your own server. You 
can copy the URL from the field and share it with social media.  If you need the HTML files so you can put on your 
own site, you need a third party tool called in5 from ajarproductions.com. 
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  Packaging for Output & Archive
To archive your document to send it the 
printer, you need the Package Feature. 
If you noticed at the bottom of your 
document window a red dot, it means 
there might be something wrong with 
your document. To see what it's alerting 
about, click on the little pop-up menu next 
to it and choose Preflight Panel. Inside 
that panel, you can see that there's a text 
error, and if you click on the little twirly 
triangle, you can see that it's overset text. 
Now click on this triangle and InDesign 
takes you right to the page and selects 
the object to fix the error. 

Once the green light appears in the 
panel and also down at the bottom of the 
document page, you can package your 
document File>Package. First, InDesign 
shows you a summary of your document. 
While this is helpful to give you a sense 
of the file, sometimes it alerts you about 
stuff that you don't need to worry about. 

Once you click Package, InDesign points out that you have to save this file first. Click Save, and at the 
bottom inDesign is asking what you want to save. This is important!!! Generally, you want a copy of 
your fonts and linked graphics, but turning on Copy Fonts checkbox will collect all of your fonts except 
for the ones from your Creative Cloud subscription. The idea is that anyone you're sending an InDesign 
CC file to is also going to have the Creative Cloud. Also, there are two checkboxes that you want think 
about. First, Include IDML (for viewing earlier version on inDesign) and Include PDF (It exports a PDF and 
puts it into the same folder as the InDesign file).  Finally, click on the Package button. .4

PACKAGE, PRINT, & EXPORTING
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To print an inDesign document go to the 
File>Print. Up comes the Print dialogue 
box and there are a lot of features in here. 
The first thing you need to do is choose 
the proper printer from the printer pop up 
menu. This tells InDesign where we're going 
to be printing. Next you can choose the 
number of copies and what page range 
you want to be printing. If the document is 
a tri-fold brochure where each panel of the 
brochure was set up as an individual page, 
you can choose whether you want to print 
these as individual pages or spreads. Next 
click is on the Setup panel where you can 
choose the paper size, meaning the paper 
that's actually in the printer. You can also 
tell InDesign to scale the document to fit 
on that paper, to do a printing a proof. You 
can also change the orientation. Next you 
can go over to the Marks and Bleed panel. 
The check boxes add marks and color bars 
around the outside of the page, and this is 
important if the document  have objects 
that bleed off the side of the page. This 
is just the basics for printing an inDesign 
document. 

.4
PACKAGE, PRINT, & EXPORTING
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a client or send a finished document to 
a printer, you should send them a PDF. To 
make a PDF, just go to File>Export. Then, 
from the format pop-up menu, you'll 
have to choose between two different PDF 
formats: PDF interactive or PDF print. The 
interactive option should only be used if 
your document has movies, or buttons, etc. 
But for the vast majority of PDFs you should 
choose Adobe PDF Print, even if you're using 
hyperlinks and bookmarks, this is a better 
choice. Now, when you click save, you get 
a lot of options to choose from. If you're 
sending this PDF to a commercial printing 
press, use one of this PDF x options. You 
need to ask your printer do they want PDF/
x-1a or something else? If you're lucky, your 
printer will come back and say you can give 
us PDF/x-4, because it is a much better 
quality PDF. But, if you don't know who's 
gonna be printing, the safest option is PDF/
x-1a or High Quality Print. If you're making 
a PDF to send it for a proof or posting it on 
your website, then, choose High Quality 
Print, but you should make some changes 
to customize it, for example, change the 
compatibility to Acrobat 6 or later. 
Next, you could choose your page range 
like Spreads if you want the pages in the 
trifold to act like a single page. If you're going to post your PDF on a website, I recommend you to turn on the Create Tagged PDF check box because this allows 

much better web SEO.  Also, if you've used hyperlinks or bookmarks, then turn on the Bookmarks and Hyperlinks check 
boxes. Note that these are the only interactive features that are saved out in a printed PDF. 
The Compression tab lets you choose the resolution from 300 down to 150 or whatever you need. Also, you can change 
the image quality to medium or maximum quality. The Marks and Bleed panel, lets you set the crop marks. If you're 
printing a document that has bleed, then you want to turn on the Use Document Bleed Settings. Again, that's if you're 
going to a commercial printing press. I suggest you to ask your printer whether or not they need the marks. If you're just 
printing this on screen, then you definitely don't wanna have that check box on. 

In the General Panel, you wanna turn on View PDF after Exporting because you wanna see my PDF after it's done. .4
PACKAGE, PRINT, & EXPORTING


